Application availability issues
Incident Report for Workable
Resolved
This incident has been resolved.
Posted Mar 28, 2020 - 05:23 PDT
Update
The issue has been resolved. Apologies!
Posted Mar 27, 2020 - 13:49 PDT
Update
We are continuing to investigate this issue.
Posted Mar 27, 2020 - 13:26 PDT
Investigating
We are experiencing issues and are currently investigating. All further updates will be posted here on our status page.
Posted Mar 27, 2020 - 12:45 PDT
This incident affected: Applicant tracking, Career pages & Αpplication forms, Resume parsing, Email sending, Sourcing with People Search, Login & signup, and Referrals.