Workable email notifications affected
Incident Report for Workable
Resolved
This incident has been resolved.
Posted Feb 22, 2023 - 05:11 PST
Investigating
We got a few reports about emails not being delivered. e.g. application confirmation emails not delivered.
Our partner is working on rectifying the issue. You can track the progress here:
https://status.mailgun.com/
Posted Feb 21, 2023 - 04:47 PST
This incident affected: Workable Recruiting (Email sending).