Application availability issues
Incident Report for Workable
Resolved
This incident has been resolved.
Posted Jun 05, 2019 - 12:25 PDT
Update
We are continuing to investigate this issue.
Posted Jun 05, 2019 - 11:49 PDT
Investigating
We are experiencing issues and are currently investigating. All further updates will be posted here on our status page.
Posted Jun 05, 2019 - 11:49 PDT
This incident affected: Applicant tracking, Career pages & Αpplication forms, Resume parsing, Email sending, Sourcing with People Search, and Login & signup.