Workable email notifications affected
Incident Report for Workable
Resolved
This incident has been resolved.
Posted Feb 28, 2023 - 03:31 PST
Monitoring
Our partner is continuing to apply mitigation tactics and closely monitoring platform performance. You can track the progress here:
https://status.mailgun.com/
Posted Feb 23, 2023 - 03:25 PST
Update
We are continuing to investigate this issue.
Posted Feb 22, 2023 - 10:33 PST
Investigating
We got a few reports about emails not being delivered. e.g. application confirmation emails not delivered.
Our partner is working on rectifying the issue. You can track the progress here:
https://status.mailgun.com/
Posted Feb 22, 2023 - 10:33 PST
This incident affected: Workable Recruiting (Email sending).