System slowness/errors
Incident Report for Workable
Resolved
The issue is now resolved, we apologize for any inconvenience.
Posted 11 months ago. Jun 08, 2018 - 04:37 PDT
Investigating
We have reports of errors and general slow running with the system, we are currently investigating and will update when this is resolved.
Posted 11 months ago. Jun 08, 2018 - 03:18 PDT