Application slowness
Incident Report for Workable
Resolved
This incident has been resolved.
Posted Apr 03, 2023 - 03:14 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2023 - 03:02 PDT
Investigating
Our users might experience slowness in loading resumes, disqualifying, sending emails and other actions within Workable app. We are investigating.
Posted Apr 03, 2023 - 02:55 PDT
This incident affected: Workable Recruiting (Resume parsing, Workable Texting, Recruiting and applicant tracking, Email sending, Workable Assessments, Workable Video Interviews, Career pages & Αpplication forms, Sourcing with People Search & AI Recruiter) and Login & signup, Referrals, E-signatures, BI Data Link.