Application availability issues
Incident Report for Workable
Resolved
Access to Workable has been resolved.
Posted Jul 17, 2020 - 14:47 PDT
Update
We are seeing performance improve and continue to monitor the issue
Posted Jul 17, 2020 - 14:39 PDT
Identified
One of our service providers appears to be experiencing downtime and this is impacting Workable services. Access to Workable may be sporadic or slow. We are monitoring and will update when possible.
Posted Jul 17, 2020 - 14:29 PDT
Investigating
We are experiencing issues and are currently investigating. All further updates will be posted here on our status page.
Posted Jul 17, 2020 - 14:18 PDT
This incident affected: Workable Recruiting (Recruiting and applicant tracking) and Login & signup.