Employee Management pages not available

Incident Report for Workable

Resolved

All Employee Management pages are loading now. Apologies for the disruption!
Posted Nov 16, 2023 - 06:25 PST

Investigating

Employee Management pages - Employee Director, Organization Chart, Onboarding and Time-Off are not responding currently. We are investigating.
Posted Nov 16, 2023 - 06:10 PST
This incident affected: Workable HR (Onboarding).