Delayed refresh for BI Data Link and professional services reports

Incident Report for Workable

Resolved

This incident has been resolved.
Posted Feb 09, 2026 - 05:46 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2026 - 02:24 PST

Identified

Data in custom reports provided by our professional services and the BI Data Link reports may be outdated due to an issue with the most recent refresh. We are working on refreshing it today.
Posted Feb 05, 2026 - 02:22 PST
This incident affected: BI Data Link.