Shortage affecting access to Workable career pages and applications
Incident Report for Workable
Resolved
Our team was able to resolve the careers page issues and all functions are now normal.
Posted Mar 26, 2021 - 08:11 PDT
Investigating
Our Workable career pages and application are experiencing shortages affecting access to the page. We are currently investigating the issue
Posted Mar 26, 2021 - 06:49 PDT
This incident affected: Workable Recruiting (Career pages & Αpplication forms).