Candidate upload delays
Incident Report for Workable
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 27, 2018 - 12:32 PDT
Investigating
There may be delays in resume uploads to Workable.
Posted 3 months ago. Aug 27, 2018 - 10:42 PDT
This incident affected: Resume parsing.