Duplicate candidate entries in job stages

Incident Report for Workable

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 09:49 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 31, 2025 - 08:53 PDT

Investigating

We’re currently investigating an issue where some candidates are appearing multiple times within the same job or stage. Additionally, certain disqualified candidates are incorrectly appearing in the qualified stages.
Posted Jul 31, 2025 - 08:02 PDT
This incident affected: Workable Recruiting (Recruiting and applicant tracking).