Delays in resume uploading
Incident Report for Workable
Resolved
This incident has been resolved.
Posted Sep 18, 2020 - 05:15 PDT
Investigating
There may be delays in resume uploads to Workable. All further updates will be posted here on our status page.
Posted Sep 18, 2020 - 04:22 PDT
This incident affected: Resume parsing.