Application availability issues

Incident Report for Workable

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 01:34 PST

Monitoring

Workable is accessible again and we are monitoring.
Posted Dec 05, 2025 - 01:17 PST

Investigating

Our service provider, Cloudflare, is experiencing network performance issues that are impacting Workable customers. They are aware of the issue and are actively working on a fix.
Posted Dec 05, 2025 - 01:01 PST
This incident affected: Workable Recruiting (Resume parsing, Workable Texting, Recruiting and applicant tracking, Email & calendar, Workable Assessments, Workable Video Interviews, Career pages & Αpplication forms, Sourcing with Search with AI, Workable AI features), Workable HR (Onboarding, Employee Management, Time-off, Time tracking, Performance reviews), and Login & signup, Newjobs.gr, Referrals, E-signatures, BI Data Link, Free Tools for Managers, Branded Job Boards, Reports.