A fix has been implemented, and all delayed events will be processed shortly. We apologize for the disruption.
Posted Oct 16, 2025 - 08:28 PDT
Investigating
Users may experience issues with calendar integrations not syncing correctly to their calendars or with Google Meet and Microsoft Teams not generating meeting links. We are investigating.
Posted Oct 16, 2025 - 06:54 PDT
This incident affected: Workable Recruiting (Email & calendar).