Performance Delays and Timeouts
Incident Report for Workable
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 12:21 PST
Investigating
We are currently experiencing delays with some of our datastores at this time. Customers may notice delays and sporadic timeouts in some areas.
Posted Nov 14, 2022 - 10:13 PST
This incident affected: Applicant tracking.