Issue with timeouts and slowness

Incident Report for Workable

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 07:38 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2025 - 07:28 PDT

Investigating

We are currently investigating this issue.
Posted Jun 25, 2025 - 07:15 PDT
This incident affected: Workable Recruiting (Resume parsing, Workable Texting, Recruiting and applicant tracking, Email sending, Workable Assessments, Workable Video Interviews, Career pages & Αpplication forms, Sourcing with Search with AI, Workable AI features), Workable HR (Onboarding, Employee Management, Time-off, Time tracking, Performance reviews), and Login & signup, Newjobs.gr, Referrals, E-signatures, Free Tools for Managers, Branded Job Boards, Reports.