BI data link reports not up to date

Incident Report for Workable

Resolved

Access to BI data has now been restored and will update soon. Thank you for your patience while we resolved this.
Posted Mar 24, 2023 - 11:31 PDT

Investigating

We identified an issue where BI data are not currently getting refreshed. All users still have access to the data but they are not currently updating. We are investigating the issue.
Posted Mar 24, 2023 - 03:04 PDT
This incident affected: BI Data Link.