Payment issues between credit card processor causing higher decline rates
Incident Report for Workable
Resolved
This incident has been resolved.
Posted Sep 21, 2023 - 10:14 PDT
Identified
Our credit card processing partner is currently experiencing issues while processing credit card transactions. This is causing a higher-than-usual decline rate. They have identified the issue and are working on fixing it. All further updates will be posted here on our status page.
Posted Sep 21, 2023 - 07:51 PDT