This incident has been resolved - apologies for the disruption!
Posted Sep 29, 2025 - 02:29 PDT
Investigating
We are currently investigating this issue.
Posted Sep 29, 2025 - 02:21 PDT
This incident affected: Workable Recruiting (Resume parsing, Workable Texting, Recruiting and applicant tracking, Email & calendar, Workable Assessments, Workable Video Interviews, Career pages & Αpplication forms, Sourcing with Search with AI, Workable AI features), Workable HR (Onboarding, Employee Management, Time-off, Time tracking, Performance reviews), and Login & signup, Newjobs.gr, Referrals, E-signatures, BI Data Link, Free Tools for Managers, Branded Job Boards, Reports.