E-Signature service disruption

Incident Report for Workable

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 07:42 PDT

Identified

We are currently experiencing a service disruption with the e-signature functionality. Users may encounter errors when sending, approving, signing, or updating e-signature templates. This issue affects e-signature workflows, including Offer Letters and employee signatures.

We are actively investigating and working with our provider to resolve the issue. Updates will be shared as they become available here: https://status.hellosign.com/incidents/hlf6fghp1h8b
Posted Aug 04, 2025 - 05:19 PDT
This incident affected: E-signatures.