Workable accessibility
Incident Report for Workable
Resolved
This incident has been resolved.
Posted Dec 16, 2020 - 08:39 PST
Update
We are continuing to investigate this issue.
Posted Dec 16, 2020 - 08:24 PST
Investigating
Our customers might experience issues and delays while accessing Workable account and Referrals portal. We are investigating.
Posted Dec 16, 2020 - 06:20 PST
This incident affected: Applicant tracking, Career pages & Αpplication forms, Resume parsing, Email sending, Sourcing with People Search, Login & signup, Referrals, and Workable Video Interviews.