Accessibility issues
Incident Report for Workable
Resolved
This incident has been resolved.
Posted Jul 14, 2020 - 00:32 PDT
Update
We are continuing to investigate this issue.
Posted Jul 14, 2020 - 00:31 PDT
Investigating
We are investigating the root causes and are taking the required actions to bring Workable back online.
Posted Jul 14, 2020 - 00:23 PDT
This incident affected: Applicant tracking, Career pages & Αpplication forms, Resume parsing, Email sending, Sourcing with People Search, Login & signup, Referrals, and Workable Video Interviews.