Reports experiencing delays

Incident Report for Workable

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 04:30 PDT

Monitoring

Reporting refresh flows are gradually recovering, and we are monitoring the results.
Posted Oct 20, 2025 - 04:13 PDT

Investigating

Our built-in and BI Data Link reports are experiencing delays due to ongoing issues with our third-party provider. Our team is closely monitoring the situation to restore the syncing process as soon as possible.
Posted Oct 20, 2025 - 03:53 PDT
This incident affected: BI Data Link and Reports.