BI Data Link reports - delayed refresh for Eastern timezone

Incident Report for Workable

Resolved

This incident has been resolved.
Posted Apr 30, 2025 - 09:29 PDT

Investigating

We’re currently experiencing a delay in the daily data refresh for Reshift databases in the Eastern timezone schedule. As a result, BI Data Link reports may display outdated information. Our team is actively working to resolve the issue and restore timely updates.

We’ll provide further updates as soon as they become available.
Posted Apr 30, 2025 - 07:27 PDT
This incident affected: BI Data Link.