Application availability issues

Incident Report for Workable

Resolved

This incident has been resolved.
Posted Jul 02, 2019 - 07:34 PDT

Investigating

We are currently investigating this issue.
Posted Jul 02, 2019 - 06:52 PDT
This incident affected: Workable Recruiting (Recruiting and applicant tracking, Career pages & Αpplication forms) and Login & signup.