Offer Letter Signage Affected
Incident Report for Workable
Resolved
This issue has been addressed by our service provider. E-Signatures are working normally. Existing offers that appear as expired may need to be re-sent.
Posted Sep 16, 2023 - 07:09 PDT
Update
We are continuing to investigate this issue.
Posted Sep 15, 2023 - 13:58 PDT
Investigating
We are currently investigating this issue with our offer letter provider. In the meantime please visit https://status.hellosign.com/ for updates.
Posted Sep 15, 2023 - 13:58 PDT
This incident affected: E-signatures.