Workable not loading on Internet Explorer/Edge

Incident Report for Workable

Resolved

This incident has been resolved.
Posted Jul 27, 2020 - 04:13 PDT

Update

We are continuing to investigate this issue.
Posted Jul 23, 2020 - 23:50 PDT

Investigating

We have received some reports of pages not loading correctly on Internet Explorer and Edge. We are currently investigating. In the meantime, you can access Workable using another browser, if possible.
Posted Jul 17, 2020 - 02:01 PDT