Workable pages timing out

Incident Report for Workable

Resolved

We’ve deployed a fix and closely monitored the situation for an extended period. There have been no further errors, and pages are now loading as expected.
We sincerely apologize for the disruption!
Posted May 16, 2025 - 01:20 PDT

Monitoring

Our customers may experience issues logging into the platform and loading various pages within the application. Some pages may time out. We are currently investigating
Posted May 15, 2025 - 10:08 PDT
This incident affected: Workable HR (Onboarding, Employee Management, Time-off), Workable Recruiting (Recruiting and applicant tracking, Workable Assessments, Workable Video Interviews, Sourcing with Search with AI), and Login & signup, Referrals, Reports.