E-signature service disruption

Incident Report for Workable

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 17:38 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 01, 2025 - 11:30 PDT

Investigating

We are currently experiencing a service disruption with the e-signature functionality. Users may encounter errors when sending, approving, signing, or updating e-signature templates. This issue affects e-signature workflows, including offer letters and employee signatures.

We are actively investigating and working with our provider to resolve the issue. Updates will be shared as they become available here:
https://status.hellosign.com/incidents/8g4fhlrn5t0r
Posted Oct 01, 2025 - 07:51 PDT
This incident affected: E-signatures.