Workable Referrals portal loading issues
Incident Report for Workable
Resolved
The issue has been resolved.
Posted Sep 10, 2020 - 02:22 PDT
Investigating
We are experiencing loading issues with our Referrals portal and are currently investigating. All further updates will be posted here on our status page.
Posted Sep 10, 2020 - 00:22 PDT
This incident affected: Referrals.