Workable pages timing out

Incident Report for Workable

Resolved

This incident has been resolved.
Posted May 15, 2025 - 04:20 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 15, 2025 - 04:13 PDT

Update

We are continuing to investigate this issue.
Posted May 15, 2025 - 04:01 PDT

Investigating

Our customers may experience issues logging into the platform and loading various pages within the application. Some pages may time out. We are currently investigating.
Posted May 15, 2025 - 04:00 PDT
This incident affected: Workable Recruiting (Resume parsing, Workable Texting, Recruiting and applicant tracking, Email & calendar, Workable Assessments, Workable Video Interviews, Career pages & Αpplication forms, Sourcing with Search with AI, Workable AI features), Workable HR (Onboarding, Employee Management, Time-off), and Login & signup, Newjobs.gr, Referrals, E-signatures, Reports.