People Search not working
Incident Report for Workable
Resolved
People Search is fully functional again, thank you for your patience.
Posted 5 months ago. May 25, 2018 - 06:09 PDT
Investigating
We are experiencing issues with our People Search sourcing tool, we are investigating. We'll be posting more updates here.
Posted 5 months ago. May 25, 2018 - 05:48 PDT