Application availability issues
Incident Report for Workable
Resolved
The technical issue causing slowdowns has been resolved. All functions have returned to normal.
Posted 11 months ago. Sep 14, 2017 - 11:11 PDT
Investigating
We are experiencing issues and are currently investigating. All further updates will be posted here on our status page.
Posted 11 months ago. Sep 14, 2017 - 08:38 PDT