Workable accessibility
Incident Report for Workable
Resolved
This incident has been resolved.
Posted Dec 05, 2019 - 01:48 PST
Investigating
Our customer might experience issues accessing Workable account and career pages. We are investigating.
Posted Dec 05, 2019 - 01:37 PST
This incident affected: Applicant tracking, Career pages & Αpplication forms, Resume parsing, Email sending, Sourcing with People Search, and Login & signup.