Issues with loading times
Incident Report for Workable
Resolved
The case has been resolved. The is no longer an outage and all accounts should function as before
Posted Apr 29, 2019 - 10:30 PDT
Investigating
We are currently investigating reports of issues with users logging into the system and having pages load from them.
Posted Apr 29, 2019 - 10:09 PDT
This incident affected: Workable Recruiting (Recruiting and applicant tracking, Email sending) and Login & signup.