Possible Video Interview delays
Incident Report for Workable
Resolved
This incident has been resolved.
Posted Oct 19, 2020 - 00:00 PDT
Identified
We have identified an issue affecting a small percentage of video interviews that causes a delay between recording and playback for candidates. This may prevent candidates from proceeding normally in a video interview.
Posted Oct 17, 2020 - 10:55 PDT
This incident affected: Workable Recruiting (Workable Video Interviews).