Workable accessibility
Incident Report for Workable
Resolved
This incident has been resolved.
Posted Jan 26, 2021 - 00:23 PST
Update
We are continuing to investigate this issue.
Posted Jan 26, 2021 - 00:23 PST
Investigating
Our customers might experience issues and delays while accessing Workable account and Referrals portal. We are investigating.
Posted Jan 25, 2021 - 23:30 PST
This incident affected: Workable Recruiting (Resume parsing, Recruiting and applicant tracking, Email sending, Workable Video Interviews, Career pages & Αpplication forms, Sourcing with People Search & AI Recruiter) and Login & signup, Referrals.