Sporadic errors
Incident Report for Workable
Resolved
This incident has been resolved, apologies for the inconvenience caused.
Posted 12 months ago. Nov 22, 2017 - 05:22 PST
Investigating
Some of our customers are reporting sporadic errors while using Workable and uploading files. We are currently investigating and will publish all updates here.
Posted 12 months ago. Nov 22, 2017 - 03:11 PST