Resume upload/view issues
Incident Report for Workable
Resolved
This incident has been resolved.
Posted 11 months ago. Oct 02, 2017 - 11:34 PDT
Investigating
We've had several reports of slow performance on candidate uploading and processing. We are currently investigating and will publish all updates here.
Posted 11 months ago. Oct 02, 2017 - 07:14 PDT