Resume Upload/View issues
Incident Report for Workable
Resolved
The previous issue in regards to resume uploads was resolved
Posted 10 months ago. Oct 11, 2017 - 10:24 PDT
Investigating
We've had several reports of slow performance on candidate uploading and processing. We are currently investigating and will publish all updates here.
Posted 10 months ago. Oct 11, 2017 - 07:29 PDT