Delays in processing Workable emails
Incident Report for Workable
Resolved
This incident seems to be resolved - Workable emails do not have any delays.

Apologies for any inconvenience this has caused!
Posted about 1 month ago. Jul 13, 2018 - 08:36 PDT
Identified
Workable email is facing issues at this time, so there may be delays in email delivery. This is affecting emails sent to candidates using Workable email, event invitations, password reset requests, new member invitations and notifications.
Posted about 1 month ago. Jul 13, 2018 - 05:21 PDT
This incident affected: Email sending.