System slowness/errors
Incident Report for Workable
Resolved
This incident has been resolved.
Posted Jun 19, 2019 - 15:07 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 19, 2019 - 13:14 PDT
Investigating
We are currently investigating these issues.
Posted Jun 19, 2019 - 12:01 PDT
This incident affected: Applicant tracking, Career pages & Αpplication forms, Resume parsing, Email sending, Sourcing with People Search, and Login & signup.