Sporadic errors
Incident Report for Workable
Resolved
This issue has been resolved. Apologies for any inconvenience.
Posted about 1 month ago. Jun 20, 2017 - 11:42 PDT
Investigating
Some of our customers are reporting sporadic errors while using Workable. We are currently investigating and will publish all updates here.
Posted about 1 month ago. Jun 20, 2017 - 08:40 PDT