SSL Certificate Issue
Incident Report for Workable
Resolved
This has been resolved - sorry for any interruption.
Posted 9 months ago. Oct 14, 2016 - 10:17 PDT
Identified
This issue is being caused by an error from our SSL issuer GlobalSign. They have identified and fixed the root problem, but due to caching a small subset of users may continue to experience problems accessing Workable. We are currently working with them to resolve.
Posted 10 months ago. Oct 13, 2016 - 12:38 PDT
Investigating
We are investigating SSL warnings some of our customers have reported which is affecting access to Workable.
Posted 10 months ago. Oct 13, 2016 - 09:12 PDT