Performance degradation
Incident Report for Workable
Resolved
We have identified the component that was causing delays and uploaded a patch that resolved the issue
Posted over 1 year ago. Mar 31, 2016 - 08:27 PDT
Investigating
Several customers are experiencing delays and degraded performance when accessing Workable. We are currently investigating. All further updates will be posted here on our status page.
Posted over 1 year ago. Mar 31, 2016 - 07:03 PDT