Sporadic errors
Incident Report for Workable
Resolved
The issue has been resolved. Apologies!
Posted 3 months ago. Jun 29, 2017 - 11:09 PDT
Investigating
Some of our customers are reporting sporadic errors while using Workable. We are currently investigating and will publish all updates here.
Posted 3 months ago. Jun 29, 2017 - 09:12 PDT