Resume upload slow processing
Incident Report for Workable
Resolved
This incident has been fully resolved now. Apologies for the disruption!
Posted about 1 month ago. May 10, 2018 - 05:12 PDT
Identified
We've had several reports of slow performance on candidate uploading and processing. We have identified the root cause of the problem and addressed it. We will post updates here when it's fully resolved.
Posted about 1 month ago. May 10, 2018 - 04:47 PDT